Author Topic: lock-up when long music plays in combat  (Read 857 times)

Offline Jaesun

  • Hero Member
  • *****
  • Posts: 572
lock-up when long music plays in combat
« on: May 04, 2012, 07:36:42 PM »
I've often had this problem, that when a long piece of MIDI music is playing while in combat, there is a chance the game will completely lock up. The music will play fine for a few minutes, then it seems to... mess up. Playing an occasional note here and there. When that happens I rip my hair and then know a crash is more than likely about to happen. I wonder if it possibly some setting I have? I have the Roland Mt-32 for music (I physically own a real MT-32) and use the Soundblaster Effects.

Is this possibly a known bug or is there some way to remedy this?

Offline Kodi

  • Newbie
  • *
  • Posts: 12
Re: lock-up when long music plays in combat
« Reply #1 on: August 22, 2012, 10:28:24 AM »
That issue has crashed games at some very inconvenient times (like half way through a big battle). It might help to turn off the music anytime a long song is playing and when you're not able to save the game. I believe Alt-T can be used to turn off the music.

Offline ProphetSword

  • Mod Designer
  • Administrator
  • Hero Member
  • *****
  • Posts: 2924
  • FRUA Lives!
    • Lands of Adventure
Re: lock-up when long music plays in combat
« Reply #2 on: August 23, 2012, 07:06:07 AM »
It's been a long time, but I think it's a known issue the imported music that's too long can cause issues with UA.  I don't know the specifics (someone else can address that), but I think it's the reason why most of the tunes will be short...or at least shorter than the default.

I'm not sure if anyone has had any success importing anything longer or not.  A good rule of thumb is to keep it as short as possible.

More Information Here:

Offline hans

  • Hero Member
  • *****
  • Posts: 2756
Re: lock-up when long music plays in combat
« Reply #3 on: August 23, 2012, 11:14:02 AM »
John Rudy's Sound and Fury: The Final Word article from issue 19 the Unlimited Adventures Newsletter addresses the size limitations of imported midis/xmis.

Some systems are able to handle slightly bigger midis than other folks' (at least, this used to be the case).  It was a matter of how their memory to run UA was allocated.  Don't ask me to get too technical, 'cuz I understand very little of the science that makes these 'pooters go. 

But, David Knott (Kaviyd) wrote an article that might shed some light on this aspect in issue 25 of the UANL, Optimizing Conventional Memory -- Update: 

I have no idea if settings on DOSBox or Dfend might effect things, as well, these days. 

I only know that I try to keep my imported music files to 9kb or less (as import-ready *.XMIs).
« Last Edit: August 23, 2012, 11:16:59 AM by hans »