Author Topic: Bug in Game08 of The Realm? Stuck in the basement.  (Read 771 times)

Offline Solo4114

  • Newbie
  • *
  • Posts: 4
Bug in Game08 of The Realm? Stuck in the basement.
« on: January 04, 2017, 08:47:43 AM »
First, I know this has been posted about previously, but I wasn't sure of the board's policies on necroing old threads (especially ones from 2011), and second, the old thread didn't actually contain a solution, just a statement that the person bringing it up had figured out a workaround (which wasn't specified).  I should also say that I am completely unfamiliar with the editing/creating side of FRUA, and have only been using it as a gaming platform, so I have no idea where to begin in editing my own way around the issue.  I could probably teach myself in time, but I thought I'd come here for what is hopefully a quick fix.

Anyway, I've been playing through Ray Dyer's fantastic "The Realm" compilation, and have just hit the point in Game08 where the bug that leads to getting stuck in the basement/dungeon kicks in.

I've retrieved the required sword, collected the tiara, and am now unable to do anything else to exit the dungeon.  When I move the party over to the trap door area, it just runs the dialogue that indicates you see the trap door.  But my character "sighs" that they haven't collected everything they came for.

The thing is, I KNOW I picked up the sword (saw the little picture) and I just got the tiara from the magically locked room.  When I check the inventory, I show a list of various items (some from the earlier part of the adventure that I haven't bothered to sell yet), including the tiara, as well as a blank line.  By that, I mean it looks like this:

Bearskin Rug


Or something to that effect.  There's a two-handed sword in one character's backpack, as well. 

I've tried this in two ways, and been bugged each time.

First, I entered the room with the evil adventurers, killed them, declined to use the scroll at the magic door, examined the trap door spot, bashed the magic door open, got the tiara, and then tried to exit.  No luck.  In this game, I'd also made it past the one gas trap, and joined with the two thieves, one of whom was unconscious.

Second, I entered the room, killed the enemy party, used the magic scroll, got the tiara, examined the trap door spot...and I'm still stuck.  In this game, I made it past the gas trap and did NOT join with the thieves.  We simply walked past each other.

I gather there's some "proper" order in which to approach the dungeon, but at this point I have no idea what it'd be.  What exactly is this bug, and how do I get around it?  I might be able to reload an old save, but at this point, my saves are all after I'm in the basement at various points.  So I can't restart the 2nd half of the adventure.  I suppose I could remove the characters and restart the whole thing, but that will also lead to characters who are artificially overleveled (and I have no idea how to edit them otherwise to get them back to the state they're in now).  Not the end of the world, but something I'd prefer to avoid if possible. 

So, what's the solution here?  How do you get out of the basement and finish the quest?

Thanks in advance for the help!
« Last Edit: January 04, 2017, 08:54:44 AM by Solo4114 »

Offline Solo4114

  • Newbie
  • *
  • Posts: 4
Re: Bug in Game08 of The Realm? Stuck in the basement.
« Reply #1 on: January 09, 2017, 08:17:49 AM »
I managed to solve this problem, although it came mostly through trial and error and figuring out the "right" order in which to do things.  For those who want to avoid the bugs I faced, here are the results of the different approaches to taking on the basement:

Scenario 1:  I crawled my way through, explored every nook and cranny, grabbed every bit of treasure I could.  I saved before the secret door with the gas trap, defeated the trap, and allowed the two female thieves to join my party.  Fought the evil party and won.  Walked over to the trapdoor.  THEN got the tiara.  Didn't use the Knock spell to open the locked door (it can be bashed or picked).  Went back to the trapdoor, and got stuck.

Scenario 2:  Same as above, but this time I simply refused to let the thieves join.  They walked away, I walked away.  I then defeated the evil party, used the knock scroll to open the door, got the tiara, and THEN walked to the trapdoor.  Still got stuck.

Scenario 3:  This time, I didn't disarm the gas trap.  Allowed the thieves to steal the sword.  Went back to the earlier part of the basement and found them, fought them, killed them, and kept the sword.  Went back to kill the evil party, then got the tiara.  Then went to the trapdoor.  Still stuck.

Scenario 4:  This time I went back to a much earlier save, from before I'd beaten the evil cleric in the orc caves.  I went back and defeated him, then returned to town.  In town, I sold off all of the gear I'd found (I hadn't done so in previous saves, I think).  I then went to the mansion, went through the dinner where you get the quest, accepted the quest, headed into the basement.  I then went DIRECTLY to the guardian room where the sword is, killed the guardian, took the sword, got the magic items from the secret room, and left.  I went directly to the coal room, disarmed the gas trap, went through, killed the two thieves outright, proceeded to the evil party encounter, killed them, used a knock scroll on the door, got the tiara, and then got a message saying I had both items so now all I needed to do was leave.  Went to the trapdoor and climbed out.  Problem solved.

I have two theories as to what's going wrong here.

Option 1 is that there's something screwy with the interaction between the Inv. system and the items you pick up.  If you have the wrong stuff, or picked things up out of order, or maybe have older "Inv." items that you haven't sold yet, the checks for the two items get screwed up and you end up getting the message that you don't have them both.  It's worth noting that the sword goes in as an "item" like any other (it's just a two-handed sword +2), but the tiara is an "inv." item.  In looking at my "inv." in one of the bad saves, I noticed that I had a blank line between two items, which was still treated as something that could be selected.  I'm wondering if maybe the problem doesn't come from that, and that the blank is supposed to be the sword or something.  I dunno.

Option 2 is that it's something to do with the two thieves you meet, and that when you meet them, for whatever reason, ANY action taken that isn't just "Kill 'em on the spot" triggers some kind of event where the sword disappears.  When you recapture the sword, I THINK it's classed as a different quest (the one with the tiara is, I think Quest 18, but reclaiming the sword is, I think, Quest 16).  So, again, the only "right" way to proceed through this is to kill the two thieves on sight.  No discussion, no "let them go," no "join the party," just "You see two thieves, they demand to know what you are doing, and you ...attack them at once!" or whatever the dialogue is.

I will say that the rest of the module, thus far, is pretty fun, although I'm wondering if there is some way to stealthily infiltrate the keep that I managed to screw up, or if you're supposed to always fight waves at the gate.  Fun battles either way.

Offline hans

  • Hero Member
  • *****
  • Posts: 2775
Re: Bug in Game08 of The Realm? Stuck in the basement.
« Reply #2 on: January 09, 2017, 10:27:31 AM »
You might not be getting much help on this topic because A: some folks haven't played it (like me) or B: some folks haven't played it since years ago.  Besides posting here, if the author is a Forum member (in this case yes: Ray), you can send them a PM, as well.   ;)

I'm glad you're enjoying UA and the work of one of its most celebrated authors.   :)
« Last Edit: January 09, 2017, 03:21:39 PM by hans »

Offline Solo4114

  • Newbie
  • *
  • Posts: 4
Re: Bug in Game08 of The Realm? Stuck in the basement.
« Reply #3 on: January 09, 2017, 11:40:34 AM »
Thanks!  Discovering Ray's stuff is pretty much what inspired me to dust off my copy of UA and give it a whirl.  I'd previously only played the first three Gold Box games (and only beat the first 2), but I'm loving The Realm thus far, and looking forward to checking out other game designs, too!

Offline Nol Drek

  • Dungeon Craft Tester
  • Hero Member
  • ***
  • Posts: 2235
    • Nol Drek's Web Site
Re: Bug in Game08 of The Realm? Stuck in the basement.
« Reply #4 on: January 09, 2017, 09:17:50 PM »
I'm glad you were able to get past the trapdoor on your own. I've played many of Ray's Realm modules myself, and I don't remember this particular bug. But you should rest assured that such bugs are few and far between.
"Into the Drachensgrab Mountains!"

Offline Ray

  • Sr. Member
  • ****
  • Posts: 319
    • Tour The Realm!
Re: Bug in Game08 of The Realm? Stuck in the basement.
« Reply #5 on: January 09, 2017, 09:27:00 PM »
Hey, Solo4114!

First, let me apologize for not finding the solution to this one.  It's a bug that I know affected one other person back in the heyday of The Realm, when lots of people were playing through.  Back then, I could still remember quest numbers without looking them up, so it was a simple matter to just have the player email me their Save game.  I just completed the quest for him and sent it back, and the game went on.

I could not, no matter how hard I tried, figure out what was causing that error.  I went through every event in the basement, checked and re-checked every quest event, and I just couldn't find the error.  (That's why I went the "Let me fix your Save Game" route, instead of just fixing the bug...).  When no one else encountered the bug, I just went on, hoping that it was something unique to that player's experience.  When I read your post, I had that horrible moment of, "It's baaaaack..."

And also the Lancelot moment at the end of Excalibur, "It's the old wound, my never healed..."

I'm sorry you ran into this, and more sorry I wasn't able to fix it for you!  I'm glad you had the patience (and incredible tenacity!) to try it again and again till it worked.  I can assure you that, if I could have figured out the problem, I absolutely would have corrected it!  Now it's happened to two people (that I know of)...I really wish I could have nailed it down.


Offline Solo4114

  • Newbie
  • *
  • Posts: 4
Re: Bug in Game08 of The Realm? Stuck in the basement.
« Reply #6 on: January 11, 2017, 07:47:11 AM »
No worries!  I mean, I'm just happy to have all these modules to play through!  And the next phase was definitely worth the effort.  I just figured I'd post how I managed to work around the bug, in case someone else gets stuck in the future.  I saw other people have hacked their way around it, but for those of us who don't really know how to use the tools in FRUA, I thought this might be a solution.  Glad to hear it's been exceedingly rare for folks! 

One thing I thought might also have contributed to the problem was that I'd been toting around "inv" items from previous designs rather than selling them all off, as well as toting around inv items from this design for a while.  Maybe something got screwed up in the game's internal tables re: how that stuff is managed/organized. 

Either way, made it past the bug and got to experience the very cool assault on the keep!  Great, atmospheric stuff.